본문 바로가기

Cisco

프레임릴레이 스위치 만들기

다이나밉스 net 설정
autostart = False
ghostios = true
mmap = ture

[localhost:7200]
    workingdir = d:\dynagen\working
[[3660]]
        image = d:\dynagen\image\c3660-jk9o3s-mz.124-15.T8.image.bin
        idlepc = 0x606480c0
        iomem = 5
        confreg=0x2102
        chassis = 3660
   
[[ROUTER fr]]
        model = 3660
        console=3000
           slot1 = NM-4T
           slot2 = NM-4T
         s1/0 = r1 s1/0
         s1/1 = r2 s1/0
         s1/2 = r3 s1/0
         s1/3 = r4 s1/0
         s2/0 = r5 s1/0
         s2/1 = r6 s1/0
  
    [[ROUTER r1]]
        model = 3660
        console=3001
        slot1 = NM-4T
                
    [[ROUTER r2]]
        model = 3660
 console=3002
 slot1 = NM-4T
          
    [[ROUTER r3]]
        model = 3660
 console=3003
 slot1 = NM-4T
                     
    [[ROUTER r4]]
        model = 3660
 console=3004
 slot1 = NM-4T

 [[ROUTER r5]]
        model = 3660
 console=3005
 slot1 = NM-4T
       
[[ROUTER r6]]
        model = 3660
 console=3006
 slot1 = NM-4T    
==========================================================================================
프레임 릴레이 스위치 설정
en
conf t
lin c 0
logg sync
exec-t 0
!
lin vty 0 4
logg sync
exec-t 0
pass telnet
login
exit
!
host FRSW
ena se cisco
no ip domain-lo
ser pass
!
frame switching
!
int s1/0
clock rate 64000
enc frame
no frame inver
frame intf-ty dce
frame lmi-ty ansi
no ip add
no sh
frame route 102 int s1/1 201
frame route 103 int s1/2 301
frame route 104 int s1/3 401
frame route 105 int s2/0 501
frame route 106 int s2/1 601
!
int s1/1
clock rate 64000
enc frame
no frame inver
frame intf-ty dce
frame lmi-ty ansi
no ip add
no sh
frame route 201 int s1/0 102
frame route 203 int s1/2 302
frame route 204 int s1/3 402
frame route 205 int s2/0 502
frame route 206 int s2/1 602
!
int s1/2
clock rate 64000
enc frame
no frame inver
frame intf-ty dce
frame lmi-ty ansi
no ip add
no sh
frame route 301 int s1/0 103
frame route 302 int s1/1 203
frame route 304 int s1/3 403
frame route 305 int s2/0 503
frame route 306 int s2/1 603
!
int s1/3
clock rate 64000
enc frame
no frame inver
frame intf-ty dce
frame lmi-ty ansi
no ip add
no sh
frame route 401 int s1/0 104
frame route 402 int s1/1 204
frame route 403 int s1/2 304
frame route 405 int s2/0 504
frame route 406 int s2/1 604
!
int s2/0
clock rate 64000
enc frame
no frame inver
frame intf-ty dce
frame lmi-ty ansi
no ip add
no sh
frame route 501 int s1/0 105
frame route 502 int s1/1 205
frame route 503 int s1/2 305
frame route 504 int s1/3 405
frame route 506 int s2/1 605
!
int s2/1
clock rate 64000
enc frame
no frame inver
frame intf-ty dce
frame lmi-ty ansi
no ip add
no sh
frame route 601 int s1/0 106
frame route 602 int s1/1 206
frame route 603 int s1/2 306
frame route 604 int s1/3 406
frame route 605 int s2/0 506
!
end
!
==========================================================
OSPF with NBMA on FR

1.공통설정 부분
en
conf t
lin c 0
logg sync
exec-t 0
!
lin vty 0 4
logg sync
exec-t 0
pass telnet
login
exit
ena se cisco
no ip domain-lo
ser pass
end
!
----------------------------------
!!!!!!!!!!! r1
en
conf t
host R1
int s1/0
encap frame
no frame inver
no sh
ip add 172.16.2.1 255.255.255.0
frame map ip 172.16.2.2 102
frame map ip 172.16.2.3 103
frame map ip 172.16.2.4 104
end
!
-----------------------------------
!!!!!!!!!!!!!! R2
en
conf t
host R2
int s1/0
encap frame
no frame inver
no sh
ip add 172.16.2.2 255.255.255.0
frame map ip 172.16.2.1 201
frame map ip 172.16.2.3 201
frame map ip 172.16.2.4 201
end
!
-----------------------------------
!!!!!!!!!!!!!! R3
en
conf t
host R3
int s1/0
encap frame
no frame inver
no sh
ip add 172.16.2.3 255.255.255.0
frame map ip 172.16.2.1 301
frame map ip 172.16.2.2 301
frame map ip 172.16.2.4 301
end
!

-----------------------------------
!!!!!!!!!!!!!! R4
en
conf t
host R4
int s1/0
encap frame
no frame inver
no sh
ip add 172.16.2.4 255.255.255.0
frame map ip 172.16.2.1 401
frame map ip 172.16.2.2 401
frame map ip 172.16.2.3 401
end
!
-------------------------------------
-------------------------------------
!!!!!!!!!!!!!! R1
en
conf t
int lo 0
ip add 1.1.1.1 255.255.255.255
ip ospf net point-to-point
!
int s1/0
ip ospf net non-broadcast
!
router ospf 100
passive-interface default
no passive-interface s1/0
router-id 1.1.1.1
neighbor 172.16.2.2 priority 0
neighbor 172.16.2.3 priority 0
neighbor 172.16.2.4 priority 0
network 172.16.2.1 0.0.0.0 area 0
end
!
debug ip ospf adj
-------------------------------------
!!!!!!!!!!!!!! R2
en
conf t
int lo 0
ip add 1.1.2.1 255.255.255.255
ip ospf net point-to-point
!
int s1/0
ip ospf net non-broadcast
!
router ospf 100
passive-interface default
no passive-interface s1/0
router-id 1.1.2.1
network 172.16.2.2 0.0.0.0 area 0
end
!
debug ip ospf adj

-------------------------------------
!!!!!!!!!!!!!! R3
en
conf t
int lo 0
ip add 1.1.3.1 255.255.255.255
ip ospf net point-to-point
!
int s1/0
ip ospf net non-broadcast
!
router ospf 100
passive-interface default
no passive-interface s1/0
router-id 1.1.3.1
network 172.16.2.3 0.0.0.0 area 0
end
!
debug ip ospf adj

-------------------------------------
!!!!!!!!!!!!!! R4
en
conf t
int lo 0
ip add 1.1.4.1 255.255.255.255
ip ospf net point-to-point
!
int s1/0
ip ospf net non-broadcast
!
router ospf 100
passive-interface default
no passive-interface s1/0
router-id 1.1.4.1
network 172.16.2.4 0.0.0.0 area 0
end
!
debug ip ospf adj

=============================================================
R1 의  DR/BDR 선출 디버그
R1#debug ip ospf adj
R1#
*Mar  1 00:04:01.955: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x80000001, process 100
R1#
*Mar  1 00:06:01.455: OSPF: end of Wait on interface Serial1/0
*Mar  1 00:06:01.455: OSPF: DR/BDR election on Serial1/0
*Mar  1 00:06:01.459: OSPF: Elect BDR 1.1.1.1
*Mar  1 00:06:01.459: OSPF: Elect DR 1.1.1.1
*Mar  1 00:06:01.463: OSPF: Elect BDR 0.0.0.0
*Mar  1 00:06:01.463: OSPF: Elect DR 1.1.1.1
*Mar  1 00:06:01.463:        DR: 1.1.1.1 (Id)   BDR: none
*Mar  1 00:06:01.467: OSPF: Starting 0.0.0.0 address 172.16.2.2 on Serial1/0
*Mar  1 00:06:01.467: OSPF: Starting 0.0.0.0 address 172.16.2.3 on Serial1/0
*Mar  1 00:06:01.467: OSPF: Starting 0.0.0.0 address 172.16.2.4 on Serial1/0
*Mar  1 00:06:01.967: OSPF: No full nbrs to build Net Lsa for interface Serial1/0
R1#
*Mar  1 00:06:24.567: OSPF: 2 Way Communication to 1.1.3.1 on Serial1/0, state 2WAY
*Mar  1 00:06:24.571: OSPF: Neighbor change Event on interface Serial1/0
*Mar  1 00:06:24.571: OSPF: DR/BDR election on Serial1/0
*Mar  1 00:06:24.575: OSPF: Elect BDR 1.1.3.1
*Mar  1 00:06:24.575: OSPF: Elect DR 1.1.1.1
*Mar  1 00:06:24.579:        DR: 1.1.1.1 (Id)   BDR: 1.1.3.1 (Id)
*Mar  1 00:06:24.579: OSPF: Send DBD to 1.1.3.1 on Serial1/0 seq 0xE31 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:24.583: OSPF: Neighbor change Event on interface Serial1/0
*Mar  1 00:06:24.587: OSPF: DR/BDR election on Serial1/0
*Mar  1 00:06:24.587: OSPF: Elect BDR 1.1.3.1
*Mar  1 00:06:24.591: OSPF: Elect DR 1.1.1.1
*Mar  1 00:06:24.591:        DR: 1.1.1.1 (Id)   BDR: 1.1.3.1 (Id)
*Mar  1 00:06:24.599: OSPF: 2 Way Communication to 1.1.2.1 on Serial1/0, state 2WAY
*Mar  1 00:06:24.599: OSPF: Neighbor change Event on interface Serial1/0
*Mar  1 00:06:24.603: OSPF: DR/BDR election on Serial1/0
*Mar  1 00:
R1#06:24.603: OSPF: Elect BDR 1.1.3.1
*Mar  1 00:06:24.607: OSPF: Elect DR 1.1.1.1
*Mar  1 00:06:24.607:        DR: 1.1.1.1 (Id)   BDR: 1.1.3.1 (Id)
*Mar  1 00:06:24.611: OSPF: Send DBD to 1.1.2.1 on Serial1/0 seq 0x24E6 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:24.615: OSPF: Neighbor change Event on interface Serial1/0
*Mar  1 00:06:24.619: OSPF: DR/BDR election on Serial1/0
*Mar  1 00:06:24.619: OSPF: Elect BDR 1.1.3.1
*Mar  1 00:06:24.619: OSPF: Elect DR 1.1.1.1
*Mar  1 00:06:24.623:        DR: 1.1.1.1 (Id)   BDR: 1.1.3.1 (Id)
*Mar  1 00:06:24.631: OSPF: 2 Way Communication to 1.1.4.1 on Serial1/0, state 2WAY
*Mar  1 00:06:24.631: OSPF: Neighbor change Event on interface Serial1/0
*Mar  1 00:06:24.631: OSPF: DR/BDR election on Serial1/0
*Mar  1 00:06:24.631: OSPF: Elect BDR 1.1.4.1
*Mar  1 00:06:24.631: OSPF: Elect DR 1.1.1.1
*Mar  1 00:06:24.631:        DR: 1.1.1.1 (Id)   BDR: 1.1.4.1 (Id)
*Mar  1 00:06:24.631: OSPF: Send DBD to 1.1.4.1 on Serial1/0 seq 0x1C05 opt 0x52
R1#flag 0x7 len 32
*Mar  1 00:06:24.631: OSPF: Neighbor change Event on interface Serial1/0
*Mar  1 00:06:24.631: OSPF: DR/BDR election on Serial1/0
*Mar  1 00:06:24.631: OSPF: Elect BDR 1.1.4.1
*Mar  1 00:06:24.631: OSPF: Elect DR 1.1.1.1
*Mar  1 00:06:24.631:        DR: 1.1.1.1 (Id)   BDR: 1.1.4.1 (Id)
R1#
*Mar  1 00:06:29.175: OSPF: Send DBD to 1.1.4.1 on Serial1/0 seq 0x1C05 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:29.179: OSPF: Retransmitting DBD to 1.1.4.1 on Serial1/0 [1]
*Mar  1 00:06:29.207: OSPF: Send DBD to 1.1.2.1 on Serial1/0 seq 0x24E6 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:29.211: OSPF: Retransmitting DBD to 1.1.2.1 on Serial1/0 [1]
*Mar  1 00:06:29.391: OSPF: Send DBD to 1.1.3.1 on Serial1/0 seq 0xE31 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:29.391: OSPF: Retransmitting DBD to 1.1.3.1 on Serial1/0 [1]
R1#
*Mar  1 00:06:33.927: OSPF: Send DBD to 1.1.4.1 on Serial1/0 seq 0x1C05 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:33.927: OSPF: Retransmitting DBD to 1.1.4.1 on Serial1/0 [2]
*Mar  1 00:06:34.031: OSPF: Send DBD to 1.1.2.1 on Serial1/0 seq 0x24E6 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:34.035: OSPF: Retransmitting DBD to 1.1.2.1 on Serial1/0 [2]
*Mar  1 00:06:34.199: OSPF: Send DBD to 1.1.3.1 on Serial1/0 seq 0xE31 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:34.203: OSPF: Retransmitting DBD to 1.1.3.1 on Serial1/0 [2]
R1#
*Mar  1 00:06:38.463: OSPF: Send DBD to 1.1.4.1 on Serial1/0 seq 0x1C05 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:38.463: OSPF: Retransmitting DBD to 1.1.4.1 on Serial1/0 [3]
*Mar  1 00:06:38.927: OSPF: Send DBD to 1.1.3.1 on Serial1/0 seq 0xE31 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:38.931: OSPF: Retransmitting DBD to 1.1.3.1 on Serial1/0 [3]
*Mar  1 00:06:38.983: OSPF: Send DBD to 1.1.2.1 on Serial1/0 seq 0x24E6 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:38.987: OSPF: Retransmitting DBD to 1.1.2.1 on Serial1/0 [3]
R1#
*Mar  1 00:06:42.659: OSPF: Rcv DBD from 1.1.2.1 on Serial1/0 seq 0x25DC opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART
*Mar  1 00:06:42.663: OSPF: NBR Negotiation Done. We are the SLAVE
*Mar  1 00:06:42.663: OSPF: Send DBD to 1.1.2.1 on Serial1/0 seq 0x25DC opt 0x52 flag 0x2 len 52
*Mar  1 00:06:42.771: OSPF: Rcv DBD from 1.1.2.1 on Serial1/0 seq 0x25DD opt 0x52 flag 0x3 len 52  mtu 1500 state EXCHANGE
*Mar  1 00:06:42.775: OSPF: Send DBD to 1.1.2.1 on Serial1/0 seq 0x25DD opt 0x52 flag 0x0 len 32
*Mar  1 00:06:42.895: OSPF: Rcv DBD from 1.1.2.1 on Serial1/0 seq 0x25DE opt 0x52 flag 0x1 len 32  mtu 1500 state EXCHANGE
*Mar  1 00:06:42.899: OSPF: Exchange Done with 1.1.2.1 on Serial1/0
*Mar  1 00:06:42.903: OSPF: Send LS REQ to 1.1.2.1 length 12 LSA count 1
*Mar  1 00:06:42.907: OSPF: Send DBD to 1.1.2.1 on Serial1/0 seq 0x25DE opt 0x52 flag 0x0 len 32
*Mar  1 00:06:42.911: OSPF: Rcv LS REQ from 1.1.2.1 on Serial1/0 length 36 LSA count 1
*Mar  1 00:06:42.915: OSPF: Send
R1#UPD to 172.16.2.2 on Serial1/0 length 40 LSA count 1
*Mar  1 00:06:42.999: OSPF: Rcv LS UPD from 1.1.2.1 on Serial1/0 length 64 LSA count 1
*Mar  1 00:06:43.003: OSPF: Synchronized with 1.1.2.1 on Serial1/0, state FULL
*Mar  1 00:06:43.003: %OSPF-5-ADJCHG: Process 100, Nbr 1.1.2.1 on Serial1/0 from LOADING to FULL, Loading Done

*Mar  1 00:06:43.123: OSPF: Send DBD to 1.1.4.1 on Serial1/0 seq 0x1C05 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:43.127: OSPF: Retransmitting DBD to 1.1.4.1 on Serial1/0 [4]
*Mar  1 00:06:43.147: OSPF: Rcv LS UPD from 1.1.2.1 on Serial1/0 length 64 LSA count 1
*Mar  1 00:06:43.511: OSPF: Build router LSA for area 0, router ID 1.1.1.1, seq 0x80000002, process 100
*Mar  1 00:06:43.515: OSPF: Build network LSA for Serial1/0, router ID 1.1.1.1
*Mar  1 00:06:43.515: OSPF: Build network LSA for Serial1/0, router ID 1.1.1.1
*Mar  1 00:06:43.599: OSPF: Send DBD to 1.1.3.1 on Serial1/0 seq 0xE31 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:43.603: OSPF: Retransmittin
R1#g DBD to 1.1.3.1 on Serial1/0 [4]
R1#
*Mar  1 00:06:48.075: OSPF: Send DBD to 1.1.4.1 on Serial1/0 seq 0x1C05 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:48.079: OSPF: Retransmitting DBD to 1.1.4.1 on Serial1/0 [5]
*Mar  1 00:06:48.535: OSPF: Send DBD to 1.1.3.1 on Serial1/0 seq 0xE31 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:48.539: OSPF: Retransmitting DBD to 1.1.3.1 on Serial1/0 [5]
R1#
*Mar  1 00:06:52.323: OSPF: Rcv DBD from 1.1.3.1 on Serial1/0 seq 0x14C4 opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART
*Mar  1 00:06:52.327: OSPF: NBR Negotiation Done. We are the SLAVE
*Mar  1 00:06:52.331: OSPF: Send DBD to 1.1.3.1 on Serial1/0 seq 0x14C4 opt 0x52 flag 0x2 len 92
*Mar  1 00:06:52.451: OSPF: Rcv DBD from 1.1.3.1 on Serial1/0 seq 0x14C5 opt 0x52 flag 0x3 len 52  mtu 1500 state EXCHANGE
*Mar  1 00:06:52.455: OSPF: Send DBD to 1.1.3.1 on Serial1/0 seq 0x14C5 opt 0x52 flag 0x0 len 32
*Mar  1 00:06:52.515: OSPF: Rcv DBD from 1.1.3.1 on Serial1/0 seq 0x14C6 opt 0x52 flag 0x1 len 32  mtu 1500 state EXCHANGE
*Mar  1 00:06:52.519: OSPF: Exchange Done with 1.1.3.1 on Serial1/0
*Mar  1 00:06:52.523: OSPF: Send LS REQ to 1.1.3.1 length 12 LSA count 1
*Mar  1 00:06:52.527: OSPF: Send DBD to 1.1.3.1 on Serial1/0 seq 0x14C6 opt 0x52 flag 0x0 len 32
*Mar  1 00:06:52.531: OSPF: Rcv LS REQ from 1.1.3.1 on Serial1/0 length 60 LSA count 3
*Mar  1 00:06:52.535: OSPF: Send
R1#UPD to 172.16.2.3 on Serial1/0 length 108 LSA count 3
*Mar  1 00:06:52.579: OSPF: Rcv LS UPD from 1.1.3.1 on Serial1/0 length 64 LSA count 1
*Mar  1 00:06:52.583: OSPF: Synchronized with 1.1.3.1 on Serial1/0, state FULL
*Mar  1 00:06:52.587: %OSPF-5-ADJCHG: Process 100, Nbr 1.1.3.1 on Serial1/0 from LOADING to FULL, Loading Done
*Mar  1 00:06:52.811: OSPF: Rcv LS UPD from 1.1.3.1 on Serial1/0 length 64 LSA count 1
*Mar  1 00:06:52.883: OSPF: Send DBD to 1.1.4.1 on Serial1/0 seq 0x1C05 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:52.887: OSPF: Retransmitting DBD to 1.1.4.1 on Serial1/0 [6]
*Mar  1 00:06:53.091: OSPF: Build network LSA for Serial1/0, router ID 1.1.1.1
*Mar  1 00:06:53.095: OSPF: Build network LSA for Serial1/0, router ID 1.1.1.1
R1#
*Mar  1 00:06:57.435: OSPF: Send DBD to 1.1.4.1 on Serial1/0 seq 0x1C05 opt 0x52 flag 0x7 len 32
*Mar  1 00:06:57.439: OSPF: Retransmitting DBD to 1.1.4.1 on Serial1/0 [7]
R1#
*Mar  1 00:07:00.875: OSPF: Rcv DBD from 1.1.4.1 on Serial1/0 seq 0x1F04 opt 0x52 flag 0x7 len 32  mtu 1500 state EXSTART
*Mar  1 00:07:00.879: OSPF: NBR Negotiation Done. We are the SLAVE
*Mar  1 00:07:00.883: OSPF: Send DBD to 1.1.4.1 on Serial1/0 seq 0x1F04 opt 0x52 flag 0x2 len 112
*Mar  1 00:07:01.015: OSPF: Rcv DBD from 1.1.4.1 on Serial1/0 seq 0x1F05 opt 0x52 flag 0x3 len 52  mtu 1500 state EXCHANGE
*Mar  1 00:07:01.019: OSPF: Send DBD to 1.1.4.1 on Serial1/0 seq 0x1F05 opt 0x52 flag 0x0 len 32
*Mar  1 00:07:01.107: OSPF: Rcv DBD from 1.1.4.1 on Serial1/0 seq 0x1F06 opt 0x52 flag 0x1 len 32  mtu 1500 state EXCHANGE
*Mar  1 00:07:01.111: OSPF: Exchange Done with 1.1.4.1 on Serial1/0
*Mar  1 00:07:01.115: OSPF: Send LS REQ to 1.1.4.1 length 12 LSA count 1
*Mar  1 00:07:01.115: OSPF: Send DBD to 1.1.4.1 on Serial1/0 seq 0x1F06 opt 0x52 flag 0x0 len 32
*Mar  1 00:07:01.115: OSPF: Rcv LS REQ from 1.1.4.1 on Serial1/0 length 72 LSA count 4
*Mar  1 00:07:01.115: OSPF: Send
R1# UPD to 172.16.2.4 on Serial1/0 length 148 LSA count 4
*Mar  1 00:07:01.219: OSPF: Rcv LS UPD from 1.1.4.1 on Serial1/0 length 64 LSA count 1
*Mar  1 00:07:01.223: OSPF: Synchronized with 1.1.4.1 on Serial1/0, state FULL
*Mar  1 00:07:01.223: %OSPF-5-ADJCHG: Process 100, Nbr 1.1.4.1 on Serial1/0 from LOADING to FULL, Loading Done
*Mar  1 00:07:01.375: OSPF: Rcv LS UPD from 1.1.4.1 on Serial1/0 length 64 LSA count 1
*Mar  1 00:07:01.727: OSPF: Build network LSA for Serial1/0, router ID 1.1.1.1
*Mar  1 00:07:01.731: OSPF: Build network LSA for Serial1/0, router ID 1.1.1.1
R1#
*Mar  1 00:07:05.879: OSPF: Neighbor change Event on interface Serial1/0
*Mar  1 00:07:05.879: OSPF: DR/BDR election on Serial1/0
*Mar  1 00:07:05.883: OSPF: Elect BDR 1.1.2.1
*Mar  1 00:07:05.883: OSPF: Elect DR 1.1.1.1
*Mar  1 00:07:05.883:        DR: 1.1.1.1 (Id)   BDR: 1.1.2.1 (Id)
*Mar  1 00:07:05.887: OSPF: Neighbor change Event on interface Serial1/0
*Mar  1 00:07:05.891: OSPF: DR/BDR election on Serial1/0
*Mar  1 00:07:05.891: OSPF: Elect BDR 1.1.2.1
*Mar  1 00:07:05.895: OSPF: Elect DR 1.1.1.1
*Mar  1 00:07:05.895:        DR: 1.1.1.1 (Id)   BDR: 1.1.2.1 (Id)
R1#
*Mar  1 00:07:14.739: OSPF: Neighbor change Event on interface Serial1/0
*Mar  1 00:07:14.743: OSPF: DR/BDR election on Serial1/0
*Mar  1 00:07:14.743: OSPF: Elect BDR 1.1.3.1
*Mar  1 00:07:14.747: OSPF: Elect DR 1.1.1.1
*Mar  1 00:07:14.747:        DR: 1.1.1.1 (Id)   BDR: 1.1.3.1 (Id)
*Mar  1 00:07:14.751: OSPF: Neighbor change Event on interface Serial1/0
*Mar  1 00:07:14.751: OSPF: DR/BDR election on Serial1/0
*Mar  1 00:07:14.755: OSPF: Elect BDR 1.1.3.1
*Mar  1 00:07:14.755: OSPF: Elect DR 1.1.1.1
*Mar  1 00:07:14.759:        DR: 1.1.1.1 (Id)   BDR: 1.1.3.1 (Id)
R1#
*Mar  1 00:07:22.955: OSPF: Neighbor change Event on interface Serial1/0
*Mar  1 00:07:22.959: OSPF: DR/BDR election on Serial1/0
*Mar  1 00:07:22.963: OSPF: Elect BDR 1.1.4.1
*Mar  1 00:07:22.963: OSPF: Elect DR 1.1.1.1
*Mar  1 00:07:22.963:        DR: 1.1.1.1 (Id)   BDR: 1.1.4.1 (Id)
*Mar  1 00:07:22.967: OSPF: Neighbor change Event on interface Serial1/0
*Mar  1 00:07:22.971: OSPF: DR/BDR election on Serial1/0
*Mar  1 00:07:22.971: OSPF: Elect BDR 1.1.4.1
*Mar  1 00:07:22.975: OSPF: Elect DR 1.1.1.1
*Mar  1 00:07:22.975:        DR: 1.1.1.1 (Id)   BDR: 1.1.4.1 (Id)

R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.2.1           1   FULL/DROTHER    00:01:53    172.16.2.2      Serial1/0
1.1.3.1           1   FULL/DROTHER    00:01:35    172.16.2.3      Serial1/0
1.1.4.1           1   FULL/BDR        00:01:40    172.16.2.4      Serial1/0
R1#show ip ospf database

            OSPF Router with ID (1.1.1.1) (Process ID 100)

                Router Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum Link count
1.1.1.1         1.1.1.1         130         0x80000002 0x00B9B1 1
1.1.2.1         1.1.2.1         131         0x80000002 0x00B5B2 1
1.1.3.1         1.1.3.1         122         0x80000002 0x00B1B3 1
1.1.4.1         1.1.4.1         113         0x80000002 0x00ADB4 1

                Net Link States (Area 0)

Link ID         ADV Router      Age         Seq#       Checksum
172.16.2.1      1.1.1.1         112         0x80000003 0x003F17
R1#show ip ospf database summary

            OSPF Router with ID (1.1.1.1) (Process ID 100)

R1#show ip ospf statistics detail

            OSPF Router with ID (1.1.1.1) (Process ID 100)

  Area 0: SPF algorithm executed 4 times

SPF 1 executed 00:05:27 ago, SPF type Full
  SPF calculation time (in msec):
  SPT    Intra  D-Intr Summ   D-Summ Ext7   D-Ext7 Total
  0      0      0      0      0      0      0      0
  LSIDs processed R:1 N:0 Stub:1 SN:0 SA:0 X7:0
  Change record
  LSIDs changed 1
  Changed LSAs. Recorded is LS ID and LS type:
  1.1.1.1(R)

SPF 2 executed 00:02:46 ago, SPF type Full
  SPF calculation time (in msec):
  SPT    Intra  D-Intr Summ   D-Summ Ext7   D-Ext7 Total
  0      4      0      0      0      0      0      4
  LSIDs processed R:2 N:1 Stub:0 SN:0 SA:0 X7:0
  Change record
  LSIDs changed 4
  Changed LSAs. Recorded is LS ID and LS type:
  1.1.2.1(R) 1.1.2.1(R) 1.1.1.1(R) 1.1.1.1(N)

SPF 3 executed 00:02:40 ago, SPF type Full
  SPF calculation time (in msec):
  SPT    Intra  D-Intr Summ   D-Summ Ext7   D-Ext7 Total
  0      0      0      0      0      0      0      0
  LSIDs processed R:3 N:1 Stub:0 SN:0 SA:0 X7:0
  Change record
  LSIDs changed 3
  Changed LSAs. Recorded is LS ID and LS type:
  1.1.3.1(R) 1.1.3.1(R) 1.1.1.1(N)

SPF 4 executed 00:02:30 ago, SPF type Full
  SPF calculation time (in msec):
  SPT    Intra  D-Intr Summ   D-Summ Ext7   D-Ext7 Total
  0      0      0      0      0      0      0      0
  LSIDs processed R:4 N:1 Stub:0 SN:0 SA:0 X7:0
  Change record
  LSIDs changed 3
  Changed LSAs. Recorded is LS ID and LS type:
  1.1.4.1(R) 1.1.4.1(R) 1.1.1.1(N)

R1#show ip ospf interface s1/0
Serial1/0 is up, line protocol is up
  Internet Address 172.16.2.1/24, Area 0
  Process ID 100, Router ID 1.1.1.1, Network Type NON_BROADCAST, Cost: 64
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 172.16.2.1
  Backup Designated router (ID) 1.1.4.1, Interface address 172.16.2.4
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:02
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 4 msec, maximum is 4 msec
  Neighbor Count is 3, Adjacent neighbor count is 3
    Adjacent with neighbor 1.1.2.1
    Adjacent with neighbor 1.1.3.1
    Adjacent with neighbor 1.1.4.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)

R1#show interface s1/0 summary

 *: interface is up
 IHQ: pkts in input hold queue     IQD: pkts dropped from input queue
 OHQ: pkts in output hold queue    OQD: pkts dropped from output queue
 RXBS: rx rate (bits/sec)          RXPS: rx rate (pkts/sec)
 TXBS: tx rate (bits/sec)          TXPS: tx rate (pkts/sec)
 TRTL: throttle count

  Interface              IHQ   IQD  OHQ   OQD  RXBS RXPS  TXBS TXPS TRTL
------------------------------------------------------------------------
* Serial1/0                0     0    0     0     0    0     0    0    0

R1#show interface s1/0 accounting
Serial1/0
                Protocol    Pkts In   Chars In   Pkts Out  Chars Out
                   Other          0          0         51        712
                      IP         61       5176         94       8088
R1#show interface s1/0 counters 

R1#show interface s1/0 counters broadcast

R1#show interface s1/0 counters protocol status
Protocols allocated:
 Serial1/0: Other, IP
R1#show interface s1/0 counters errors        

R1#show interface s1/0               
Serial1/0 is up, line protocol is up
  Hardware is M4T
  Internet address is 172.16.2.1/24
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  CRC checking enabled
  LMI enq sent  53, LMI stat recvd 54, LMI upd recvd 0, DTE LMI up
  LMI enq recvd 0, LMI stat sent  0, LMI upd sent  0
  LMI DLCI 0  LMI type is ANSI Annex D  frame relay DTE  segmentation inactive
  FR SVC disabled, LAPF state down
  Broadcast queue 0/64, broadcasts sent/dropped 0/0, interface broadcasts 0
  Last input 00:00:07, output 00:00:07, output hang never
  Last clearing of "show interface" counters 00:08:59
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/2/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     122 packets input, 6820 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     156 packets output, 9422 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     1 unknown protocol drops
     1 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R1#show frame-relay pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          3            0            0            0
  Switched       0            0            0            0
  Unused         0            2            0            0

DLCI = 102, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 26            output pkts 37           in bytes 2144     
  out bytes 3152           dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 0         out bcast bytes 0        
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:09:33, last time pvc status changed 00:08:51
         
DLCI = 103, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 24            output pkts 34           in bytes 2032     
  out bytes 2956           dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 0         out bcast bytes 0        
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:09:36, last time pvc status changed 00:08:44
         
DLCI = 104, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/0

  input pkts 22            output pkts 32           in bytes 1924     
  out bytes 2808           dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 0         out bcast bytes 0        
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:09:40, last time pvc status changed 00:08:38
         
DLCI = 105, DLCI USAGE = UNUSED, PVC STATUS = INACTIVE, INTERFACE = Serial1/0

  input pkts 0             output pkts 0            in bytes 0        
  out bytes 0              dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 0         out bcast bytes 0        
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:09:41, last time pvc status changed 00:09:41
         
DLCI = 106, DLCI USAGE = UNUSED, PVC STATUS = INACTIVE, INTERFACE = Serial1/0

  input pkts 0             output pkts 0            in bytes 0        
  out bytes 0              dropped pkts 0           in pkts dropped 0        
  out pkts dropped 0                out bytes dropped 0        
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0        
  out BECN pkts 0          in DE pkts 0             out DE pkts 0        
  out bcast pkts 0         out bcast bytes 0        
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:09:43, last time pvc status changed 00:09:43

R1#show frame-relay map
Serial1/0 (up): ip 172.16.2.2 dlci 102(0x66,0x1860), static,
              CISCO, status defined, active
Serial1/0 (up): ip 172.16.2.3 dlci 103(0x67,0x1870), static,
              CISCO, status defined, active
Serial1/0 (up): ip 172.16.2.4 dlci 104(0x68,0x1880), static,
              CISCO, status defined, active

R1#show frame-relay lmi

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 62               Num Status msgs Rcvd 63
  Num Update Status Rcvd 0              Num Status Timeouts 0
  Last Full Status Req 00:00:25         Last Full Status Rcvd 00:00:25

R1#show frame-relay ip tcp header-compression

R1#show frame-relay traffic
Frame Relay statistics:
        ARP requests sent 0, ARP replies sent 0
        ARP request recvd 0, ARP replies recvd 0
R1#show frame-relay end-to-end keepalive
End-to-end Keepalive Statistics for Interface Serial1/0 (Frame Relay DTE)