본문 바로가기

NCS/NW운영관리

Configure HSRP, VRRP and GLBP

Topology and Envrionment

 

GNS3 version : 2.03

GNS3 VM

L2 IOU : i86bi-linux-l2-adventerprisek9-15.2c.bin

L3 IOU : i86bi-linux-l3-adventerprisek9-15.4.1T.bin

 

 

 

 

OR

EVE-ng 2.0.3-59

QEMU : 2.4.0

L2 IOU : i86bi-linux-l2-adventerprisek9-15.2c.bin

L3 IOU : i86bi-linux-l3-adventerprisek9-15.4.1T.bin

 

 

 

 

 

HSRP Setting

HSRP.zip

 IOU1

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

hostname CSW1

no ip cef

no cdp run
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 exit
interface Loopback1
 ip address 192.168.8.8 255.255.255.255
 ip ospf network point-to-point
 exit
interface Ethernet0/0
 description face to iou2's e0/0
 no switchport
 ip address 10.1.12.1 255.255.255.0
 no shutdown
 exit
interface Ethernet0/1
 description face to iou3's e0/1
 no switchport
 ip address 10.1.13.1 255.255.255.0
 no shutdown
 exit
router ospf 1
 router-id 1.1.1.1
 redistribute connected subnets
 network 10.1.12.1 0.0.0.0 area 0
 network 10.1.13.1 0.0.0.0 area 0

 IOU2 

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

hostname DSW2

no ip cef

no cdp run
ip dhcp excluded-address 10.1.4.128 10.1.4.254
ip dhcp excluded-address 10.1.5.128 10.1.5.254
ip dhcp excluded-address 10.1.6.128 10.1.6.254
ip dhcp excluded-address 10.1.7.128 10.1.7.254
!
ip dhcp pool vlan4
 network 10.1.4.0 255.255.255.0
 default-router 10.1.4.254
 dns-server 192.168.8.2
 lease 0 8
 exit
ip dhcp pool vlan5
 network 10.1.5.0 255.255.255.0
 default-router 10.1.5.254
 dns-server 192.168.8.2
 lease 0 8
 exit
ip dhcp pool vlan6
 network 10.1.6.0 255.255.255.0
 default-router 10.1.6.254
 dns-server 192.168.8.2
 lease 0 8
 exit
ip dhcp pool vlan7
 network 10.1.7.0 255.255.255.0
 default-router 10.1.7.254
 dns-server 192.168.8.2
 lease 0 8
 exit
no ip cef

no cdp run
!
track 12 interface Ethernet0/0 line-protocol
 carrier-delay
 exit

track 18 ip sla 18

!

ip sla 18
 udp-jitter 10.1.12.1 50000
 frequency 5

 exit
ip sla schedule 18 life forever start-time now
!
interface Loopback0
 ip address 1.1.1.2 255.255.255.255
 exit
interface Ethernet0/0
 description face to iou1's e0/0
 no switchport
 ip address 10.1.12.2 255.255.255.0
 no shutdown

interface Ethernet0/1
 switchport access vlan 4
 switchport mode access
!
interface Ethernet0/2
 switchport access vlan 5
 switchport mode access
!
interface Ethernet0/3
 switchport access vlan 6
 switchport mode access
!
interface Ethernet1/0
 switchport access vlan 7
 switchport mode access
!
interface Ethernet1/2
 description face to iou3's e1/2
 no switchport
 ip address 10.1.23.2 255.255.255.0
 no shutdown
 exit

!
interface Vlan4
 ip address 10.1.4.252 255.255.255.0
 standby 4 ip 10.1.4.254
 standby 4 priority 110
 standby 4 preempt delay minimum 3 reload 6
 standby 4 name vlan4
 standby 4 track 12 decrement 20
 standby 4 track 18 decrement 20

 no shutdown

 exit
!
interface Vlan5
 ip address 10.1.5.252 255.255.255.0
 standby 5 ip 10.1.5.254
 standby 5 priority 110
 standby 5 preempt delay minimum 3 reload 6
 standby 5 name vlan5
 standby 5 track 12 decrement 20
 standby 5 track 18 decrement 20

 no shutdown

 exit
!
interface Vlan6
 ip address 10.1.6.252 255.255.255.0
 standby 6 ip 10.1.6.254
 standby 6 preempt delay minimum 3 reload 6
 standby 6 name vlan6
 standby 6 track 12 decrement 20

 standby 6 track 18 decrement 20

 no shutdown

 exit
!
interface Vlan7
 ip address 10.1.7.252 255.255.255.0
 standby 7 ip 10.1.7.254
 standby 7 preempt delay minimum 3 reload 6
 standby 7 name vlan7
 standby 7 track 12 decrement 20

 standby 7 track 18 decrement 20

 no shutdown

 exit
!
router ospf 1
 router-id 1.1.1.2
 network 10.1.4.252 0.0.0.0 area 0
 network 10.1.5.252 0.0.0.0 area 0
 network 10.1.12.2 0.0.0.0 area 0
 network 10.1.23.2 0.0.0.0 area 0
 exit

 

 IOU3

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

no ip cef

no cdp run

!
hostname DSW3
!
ip dhcp excluded-address 10.1.4.1 10.1.4.127
ip dhcp excluded-address 10.1.5.1 10.1.5.127
ip dhcp excluded-address 10.1.6.1 10.1.6.127
ip dhcp excluded-address 10.1.7.1 10.1.7.127
!
ip dhcp pool vlan4
 network 10.1.4.0 255.255.255.0
 default-router 10.1.4.254
 dns-server 192.168.8.2
 lease 0 8
!
ip dhcp pool vlan5
 network 10.1.5.0 255.255.255.0
 default-router 10.1.5.254
 dns-server 192.168.8.2
 lease 0 8
!
ip dhcp pool vlan6
 network 10.1.6.0 255.255.255.0
 default-router 10.1.6.254
 dns-server 192.168.8.2
 lease 0 8
!
ip dhcp pool vlan7
 network 10.1.7.0 255.255.255.0
 default-router 10.1.7.254
 dns-server 192.168.8.2
 lease 0 8
!
track 13 interface Ethernet0/1 line-protocol
 carrier-delay
!
track 18 ip sla 18

!
interface Loopback0
 ip address 1.1.1.3 255.255.255.255
!
interface Ethernet0/1
 description face to iou1's e0/1
 no switchport
 ip address 10.1.13.3 255.255.255.0
 no shutdown
 exit
interface Ethernet0/2
 switchport access vlan 4
 switchport mode access
!
interface Ethernet0/3
 switchport access vlan 5
 switchport mode access
!
interface Ethernet1/0
 switchport access vlan 6
 switchport mode access
!
interface Ethernet1/1
 switchport access vlan 7
 switchport mode access
!
interface Ethernet1/2
 description face to iou2's e1/2
 no switchport
 ip address 10.1.23.3 255.255.255.0
 no shutdown
 exit
!
interface Vlan4
 ip address 10.1.4.253 255.255.255.0
 standby 4 ip 10.1.4.254
 standby 4 preempt delay minimum 3 reload 6
 standby 4 name vlan4
 standby 4 track 12 decrement 20

 standby 4 track 18 decrement 20

 no shutdown

 exit
!
interface Vlan5
 ip address 10.1.5.253 255.255.255.0
 standby 5 ip 10.1.5.254
 standby 5 preempt delay minimum 3 reload 6
 standby 5 name vlan5
 standby 5 track 12 decrement 20

 standby 5 track 18 decrement 20

 no shutdown

 exit
!
interface Vlan6
 ip address 10.1.6.253 255.255.255.0
 standby 6 ip 10.1.6.254
 standby 6 priority 110
 standby 6 preempt delay minimum 3 reload 6
 standby 6 name vlan6
 standby 6 track 12 decrement 20
 standby 6 track 18 decrement 20

 no shutdown

 exit
!
interface Vlan7
 ip address 10.1.7.253 255.255.255.0
 standby 7 ip 10.1.7.254
 standby 7 priority 110
 standby 7 preempt delay minimum 3 reload 6
 standby 7 name vlan7
 standby 7 track 12 decrement 20
 standby 7 track 18 decrement 20

 no shutdown

 exit
!
router ospf 1
 router-id 1.1.1.3
 network 10.1.6.253 0.0.0.0 area 0
 network 10.1.7.253 0.0.0.0 area 0
 network 10.1.13.3 0.0.0.0 area 0
 network 10.1.23.3 0.0.0.0 area 0
!
ip sla 18
 udp-jitter 10.1.12.1 50000
 frequency 5
ip sla schedule 18 life forever start-time now
 exit

 

 IOU4

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

no ip cef

no cdp run

!
hostname ASW4
!
no ip domain-lookup
!
interface range Ethernet0/0-3
 switchport access vlan 4
 switchport mode access
!
interface range Ethernet1/0-3
 switchport access vlan 4
 switchport mode access
!
interface range Ethernet2/0-3
 switchport access vlan 4
 switchport mode access
!
interface range Ethernet3/0-3
 switchport access vlan 4
 switchport mode access
end

 IOU5

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

no ip cef

no cdp run

!
hostname ASW5
!
no ip domain-lookup
!
interface range Ethernet0/0-3
 switchport access vlan 5
 switchport mode access
!
interface range Ethernet1/0-3
 switchport access vlan 5
 switchport mode access
!
interface range Ethernet2/0-3
 switchport access vlan 5
 switchport mode access
!
interface range Ethernet3/0-3
 switchport access vlan 5
 switchport mode access
end

 IOU6

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

no ip cef

no cdp run

!
hostname ASW6
!
no ip domain-lookup
!
interface range Ethernet0/0-3
 switchport access vlan 6
 switchport mode access
!
interface range Ethernet1/0-3
 switchport access vlan 6
 switchport mode access
!
interface range Ethernet2/0-3
 switchport access vlan 6
 switchport mode access
!
interface range Ethernet3/0-3
 switchport access vlan 6
 switchport mode access
end

 IOU7

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

no ip cef

no cdp run

!
hostname ASW7
!
no ip domain-lookup
!
interface range Ethernet0/0-3
 switchport access vlan 7
 switchport mode access
!
interface range Ethernet1/0-3
 switchport access vlan 7
 switchport mode access
!
interface range Ethernet2/0-3
 switchport access vlan 7
 switchport mode access
!
interface range Ethernet3/0-3
 switchport access vlan 7
 switchport mode access
end

 

 

VRRP Setting 

VRRP.zip

 

 IOU1

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

hostname CSW1

no ip cef

no cdp run
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 exit
interface Loopback1
 ip address 192.168.8.8 255.255.255.255
 ip ospf network point-to-point
 exit
interface Ethernet0/0
 description face to iou2's e0/0
 no switchport
 ip address 10.1.12.1 255.255.255.0
 no shutdown
 exit
interface Ethernet0/1
 description face to iou3's e0/1
 no switchport
 ip address 10.1.13.1 255.255.255.0
 no shutdown
 exit
router ospf 1
 router-id 1.1.1.1
 redistribute connected subnets
 network 10.1.12.1 0.0.0.0 area 0
 network 10.1.13.1 0.0.0.0 area 0

 IOU2

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

hostname DSW2

no ip cef

no cdp run
ip dhcp excluded-address 10.1.4.128 10.1.4.254
ip dhcp excluded-address 10.1.5.128 10.1.5.254
ip dhcp excluded-address 10.1.6.128 10.1.6.254
ip dhcp excluded-address 10.1.7.128 10.1.7.254
!
ip dhcp pool vlan4
 network 10.1.4.0 255.255.255.0
 default-router 10.1.4.254
 dns-server 192.168.8.2
 lease 0 8
 exit
ip dhcp pool vlan5
 network 10.1.5.0 255.255.255.0
 default-router 10.1.5.254
 dns-server 192.168.8.2
 lease 0 8
 exit
ip dhcp pool vlan6
 network 10.1.6.0 255.255.255.0
 default-router 10.1.6.254
 dns-server 192.168.8.2
 lease 0 8
 exit
ip dhcp pool vlan7
 network 10.1.7.0 255.255.255.0
 default-router 10.1.7.254
 dns-server 192.168.8.2
 lease 0 8
 exit
no ip cef

no cdp run
!
track 12 interface Ethernet0/0 line-protocol
 carrier-delay
 exit

track 18 ip sla 18

!

ip sla 18
 udp-jitter 10.1.12.1 50000
 frequency 5

 exit
ip sla schedule 18 life forever start-time now
!
interface Loopback0
 ip address 1.1.1.2 255.255.255.255
 exit
interface Ethernet0/0
 description face to iou1's e0/0
 no switchport
 ip address 10.1.12.2 255.255.255.0
 no shutdown

interface Ethernet0/1
 switchport access vlan 4
 switchport mode access
!
interface Ethernet0/2
 switchport access vlan 5
 switchport mode access
!
interface Ethernet0/3
 switchport access vlan 6
 switchport mode access
!
interface Ethernet1/0
 switchport access vlan 7
 switchport mode access
!
interface Ethernet1/2
 description face to iou3's e1/2
 no switchport
 ip address 10.1.23.2 255.255.255.0
 no shutdown
 exit

!
interface Vlan4
 ip address 10.1.4.252 255.255.255.0
 vrrp 4 ip 10.1.4.254

 vrrp 4 preempt delay minimum 30

 vrrp 4 priority 110

 vrrp 4 track 12 decrement 20

 vrrp 4 track 18 decrement 20

 
interface Vlan5
 ip address 10.1.5.252 255.255.255.0
 vrrp 5 ip 10.1.5.254

 vrrp 5 preempt delay minimum 30

 vrrp 5 priority 110

 vrrp 5 track 12 decrement 20

 vrrp 5 track 18 decrement 20


!
interface Vlan6
 ip address 10.1.6.252 255.255.255.0
 vrrp 6 ip 10.1.6.254

 vrrp 6 preempt delay minimum 30

 vrrp 6 priority 100

 vrrp 6 timer learn

 vrrp 6 track 12 decrement 20

 vrrp 6 track 18 decrement 20


!
interface Vlan7
 ip address 10.1.7.252 255.255.255.0
 vrrp 7 ip 10.1.7.254

 vrrp 7 preempt delay minimum 30

 vrrp 7 priority 100

 vrrp 7 timer learn

 vrrp 7 track 12 decrement 20

 vrrp 7 track 18 decrement 20

 exit
!
router ospf 1
 router-id 1.1.1.2
 network 10.1.4.252 0.0.0.0 area 0
 network 10.1.5.252 0.0.0.0 area 0
 network 10.1.12.2 0.0.0.0 area 0
 network 10.1.23.2 0.0.0.0 area 0
 exit

 IOU3

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

no ip cef

no cdp run

!
hostname DSW3
!
ip dhcp excluded-address 10.1.4.1 10.1.4.127
ip dhcp excluded-address 10.1.5.1 10.1.5.127
ip dhcp excluded-address 10.1.6.1 10.1.6.127
ip dhcp excluded-address 10.1.7.1 10.1.7.127
!
ip dhcp pool vlan4
 network 10.1.4.0 255.255.255.0
 default-router 10.1.4.254
 dns-server 192.168.8.2
 lease 0 8
!
ip dhcp pool vlan5
 network 10.1.5.0 255.255.255.0
 default-router 10.1.5.254
 dns-server 192.168.8.2
 lease 0 8
!
ip dhcp pool vlan6
 network 10.1.6.0 255.255.255.0
 default-router 10.1.6.254
 dns-server 192.168.8.2
 lease 0 8
!
ip dhcp pool vlan7
 network 10.1.7.0 255.255.255.0
 default-router 10.1.7.254
 dns-server 192.168.8.2
 lease 0 8
!
track 13 interface Ethernet0/1 line-protocol
 carrier-delay
!
track 18 ip sla 18

!
interface Loopback0
 ip address 1.1.1.3 255.255.255.255
!
interface Ethernet0/1
 description face to iou1's e0/1
 no switchport
 ip address 10.1.13.3 255.255.255.0
 no shutdown
 exit
interface Ethernet0/2
 switchport access vlan 4
 switchport mode access
!
interface Ethernet0/3
 switchport access vlan 5
 switchport mode access
!
interface Ethernet1/0
 switchport access vlan 6
 switchport mode access
!
interface Ethernet1/1
 switchport access vlan 7
 switchport mode access
!
interface Ethernet1/2
 description face to iou2's e1/2
 no switchport
 ip address 10.1.23.3 255.255.255.0
 no shutdown
 exit
!
interface Vlan4
 ip address 10.1.4.253 255.255.255.0
 vrrp 4 ip 10.1.4.254

 vrrp 4 timers learn

 vrrp 4 preempt delay minimum 30

 vrrp 4 track 13 decrement 20

 vrrp 4 track 18 decrement 20

 
!
interface Vlan5
 ip address 10.1.5.253 255.255.255.0
 vrrp 5 ip 10.1.5.254

 vrrp 5 timers learn

 vrrp 5 preempt delay minimum 30

 vrrp 5 track 13 decrement 20

 vrrp 5 track 18 decrement 20

 
!
interface Vlan6
 ip address 10.1.6.253 255.255.255.0
 vrrp 6 ip 10.1.6.254

 vrrp 6 preempt delay minimum 30

 vrrp 6 priority 110

 vrrp 6 track 12 decrement 20

 vrrp 6 track 18 decrement 20


interface Vlan7
 ip address 10.1.7.253 255.255.255.0
 vrrp 7 ip 10.1.7.254

 vrrp 7 preempt delay minimum 30

 vrrp 7 priority 110

 vrrp 7 track 12 decrement 20

 vrrp 7 track 18 decrement 20


router ospf 1
 router-id 1.1.1.3
 network 10.1.6.253 0.0.0.0 area 0
 network 10.1.7.253 0.0.0.0 area 0
 network 10.1.13.3 0.0.0.0 area 0
 network 10.1.23.3 0.0.0.0 area 0
!
ip sla 18
 udp-jitter 10.1.12.1 50000
 frequency 5
ip sla schedule 18 life forever start-time now
 exit

 IOU4

Do configure same as the HSRP configuraton.

 IOU5

Do configure same as the HSRP configuraton.

 IOU6

Do configure same as the HSRP configuraton.

 IOU7

Do configure same as the HSRP configuraton.

 

 

VRRP Setting : assigned two virtual ip address on single interface

VRRP-1.zip

 IOU1

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

hostname CSW1

no ip cef

no cdp run
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 exit
interface Loopback1
 ip address 192.168.8.8 255.255.255.255
 ip ospf network point-to-point
 exit
interface Ethernet0/0
 description face to iou2's e0/0
 no switchport
 ip address 10.1.12.1 255.255.255.0
 no shutdown
 exit
interface Ethernet0/1
 description face to iou3's e0/1
 no switchport
 ip address 10.1.13.1 255.255.255.0
 no shutdown
 exit
router ospf 1
 router-id 1.1.1.1
 redistribute connected subnets
 network 10.1.12.1 0.0.0.0 area 0
 network 10.1.13.1 0.0.0.0 area 0

 IOU2

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

hostname DSW2

no ip cef

no cdp run
ip dhcp excluded-address 10.1.4.128 10.1.4.254
ip dhcp excluded-address 10.1.5.128 10.1.5.254
ip dhcp excluded-address 10.1.6.128 10.1.6.254
ip dhcp excluded-address 10.1.7.128 10.1.7.254
!
ip dhcp pool vlan4
 network 10.1.4.0 255.255.255.0
 default-router 10.1.4.254
 dns-server 192.168.8.2
 lease 0 8
 exit
ip dhcp pool vlan5
 network 10.1.5.0 255.255.255.0
 default-router 10.1.5.254
 dns-server 192.168.8.2
 lease 0 8
 exit
ip dhcp pool vlan6
 network 10.1.6.0 255.255.255.0
 default-router 10.1.6.254
 dns-server 192.168.8.2
 lease 0 8
 exit
ip dhcp pool vlan7
 network 10.1.7.0 255.255.255.0
 default-router 10.1.7.254
 dns-server 192.168.8.2
 lease 0 8
 exit
no ip cef

no cdp run
!
track 12 interface Ethernet0/0 line-protocol
track 22 ip sla 22
ip sla 22
 udp-jitter 10.1.12.1 50000 source-ip 10.1.12.2 interval 5
 exit
ip sla schedule 22 start-time now life forever

!
interface Loopback0
 ip address 1.1.1.2 255.255.255.255
 exit
interface Ethernet0/0
 description face to iou1's e0/0
 no switchport
 ip address 10.1.12.2 255.255.255.0
 no shutdown

interface Ethernet0/1
 switchport access vlan 4
 switchport mode access
!
interface Ethernet0/2
 switchport access vlan 5
 switchport mode access
!
interface Ethernet0/3
 switchport access vlan 6
 switchport mode access
!
interface Ethernet1/0
 switchport access vlan 7
 switchport mode access
!
interface Ethernet1/2
 description face to iou3's e1/2
 no switchport
 ip address 10.1.23.2 255.255.255.0
 no shutdown
 exit

!
interface Vlan4
 ip address 10.1.4.252 255.255.255.0
 vrrp 4 ip 10.1.4.250
 vrrp 4 priority 110
 vrrp 4 preempt delay minimum 30
 vrrp 4 timers advertise msec 100
 vrrp 4 track 12 decrement 20
 vrrp 4 track 22 decrement 20
 vrrp 44 ip 10.1.4.251
 vrrp 44 priority 100
 vrrp 44 preempt delay minimum 30
 vrrp 44 timers learn
 vrrp 44 track 12 decrement 20
 vrrp 44 track 22 decrement 20
!
interface Vlan5
 ip address 10.1.5.252 255.255.255.0
 vrrp 5 ip 10.1.5.250
 vrrp 5 priority 110
 vrrp 5 preempt delay minimum 30
 vrrp 5 timers advertise msec 100
 vrrp 5 track 12 decrement 20
 vrrp 5 track 22 decrement 20
 vrrp 55 ip 10.1.5.251
 vrrp 55 priority 100
 vrrp 55 preempt delay minimum 30
 vrrp 55 timers learn
 vrrp 55 track 12 decrement 20
 vrrp 55 track 22 decrement 20
!
interface Vlan6
 ip address 10.1.6.252 255.255.255.0
 vrrp 6 ip 10.1.6.250
 vrrp 6 priority 100
 vrrp 6 preempt delay minimum 30
 vrrp 6 timers learn
 vrrp 6 track 12 decrement 20
 vrrp 6 track 22 decrement 20
 vrrp 66 ip 10.1.6.251
 vrrp 66 priority 110
 vrrp 66 preempt delay minimum 30
 vrrp 66 timers advertise msec 100
 vrrp 66 track 12 decrement 20
 vrrp 66 track 22 decrement 20
!
interface Vlan7
 ip address 10.1.7.252 255.255.255.0
 vrrp 7 ip 10.1.7.250
 vrrp 7 priority 100
 vrrp 7 preempt delay minimum 30
 vrrp 7 timers learn
 vrrp 7 track 12 decrement 20
 vrrp 7 track 22 decrement 20
 vrrp 77 ip 10.1.7.251
 vrrp 77 priority 110
 vrrp 77 preempt delay minimum 30
 vrrp 77 timers advertise msec 100
 vrrp 77 track 12 decrement 20
 vrrp 77 track 22 decrement 20

 exit
!
router ospf 1
 router-id 1.1.1.2
 network 10.1.4.252 0.0.0.0 area 0
 network 10.1.5.252 0.0.0.0 area 0
 network 10.1.12.2 0.0.0.0 area 0
 network 10.1.23.2 0.0.0.0 area 0
 exit

!

! access-list 100 permit ip host 10.1.4.252 host 224.0.0.18
access-list 100 permit ip host 10.1.4.253 host 224.0.0.18
! access-list 100 permit ip host 10.1.5.252 host 224.0.0.18
access-list 100 permit ip host 10.1.5.253 host 224.0.0.18
! access-list 100 permit ip host 10.1.6.252 host 224.0.0.18
access-list 100 permit ip host 10.1.6.253 host 224.0.0.18
! access-list 100 permit ip host 10.1.7.252 host 224.0.0.18
access-list 100 permit ip host 10.1.7.253 host 224.0.0.18
access-list 100 deny ip any host 224.0.0.18
access-list 100 permit ip any any
!
interface vlan 4
 ip access-group 100 in
 exit
interface vlan 5
 ip access-group 100 in
 exit
interface vlan 6
 ip access-group 100 in
 exit
interface vlan 7
 ip access-group 100 in
 exit

 

 IOU3

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

no ip cef

no cdp run

!
hostname DSW3
!
ip dhcp excluded-address 10.1.4.1 10.1.4.127
ip dhcp excluded-address 10.1.5.1 10.1.5.127
ip dhcp excluded-address 10.1.6.1 10.1.6.127
ip dhcp excluded-address 10.1.7.1 10.1.7.127
!
ip dhcp pool vlan4
 network 10.1.4.0 255.255.255.0
 default-router 10.1.4.254
 dns-server 192.168.8.2
 lease 0 8
!
ip dhcp pool vlan5
 network 10.1.5.0 255.255.255.0
 default-router 10.1.5.254
 dns-server 192.168.8.2
 lease 0 8
!
ip dhcp pool vlan6
 network 10.1.6.0 255.255.255.0
 default-router 10.1.6.254
 dns-server 192.168.8.2
 lease 0 8
!
ip dhcp pool vlan7
 network 10.1.7.0 255.255.255.0
 default-router 10.1.7.254
 dns-server 192.168.8.2
 lease 0 8
!
track 13 interface Ethernet0/1 line-protocol
track 33 ip sla 33
ip sla 33
 icmp-echo 10.1.13.1 source-ip 10.1.13.3
 exit
ip sla schedule 33 start-time now life forever

!
interface Loopback0
 ip address 1.1.1.3 255.255.255.255
!
interface Ethernet0/1
 description face to iou1's e0/1
 no switchport
 ip address 10.1.13.3 255.255.255.0
 no shutdown
 exit
interface Ethernet0/2
 switchport access vlan 4
 switchport mode access
!
interface Ethernet0/3
 switchport access vlan 5
 switchport mode access
!
interface Ethernet1/0
 switchport access vlan 6
 switchport mode access
!
interface Ethernet1/1
 switchport access vlan 7
 switchport mode access
!
interface Ethernet1/2
 description face to iou2's e1/2
 no switchport
 ip address 10.1.23.3 255.255.255.0
 no shutdown
 exit
!
interface Vlan4
 ip address 10.1.4.253 255.255.255.0
 vrrp 4 ip 10.1.4.250
 vrrp 4 priority 100
 vrrp 4 preempt delay minimum 30
 vrrp 4 timers learn

 vrrp 4 track 13 decrement 20
 vrrp 4 track 33 decrement 20
 vrrp 44 ip 10.1.4.251
 vrrp 44 priority 110
 vrrp 44 preempt delay minimum 30
 vrrp 44 timers advertise msec 100

 vrrp 44 track 13 decrement 20
 vrrp 44 track 33 decrement 20
!
interface Vlan5
 ip address 10.1.5.253 255.255.255.0
 vrrp 5 ip 10.1.5.250
 vrrp 5 priority 100
 vrrp 5 preempt delay minimum 30
 vrrp 5 timers learn
 vrrp 5 track 13 decrement 20
 vrrp 5 track 33 decrement 20
 vrrp 55 ip 10.1.5.251
 vrrp 55 priority 110
 vrrp 55 preempt delay minimum 30
 vrrp 55 timers advertise msec 100
 vrrp 55 track 13 decrement 20
 vrrp 55 track 33 decrement 20
!
interface Vlan6
 ip address 10.1.6.253 255.255.255.0
 vrrp 6 ip 10.1.6.250
 vrrp 6 priority 110
 vrrp 6 preempt delay minimum 30
 vrrp 6 timers advertise msec 100

 vrrp 6 track 13 decrement 20
 vrrp 6 track 33 decrement 20
 vrrp 66 ip 10.1.6.251
 vrrp 66 priority 100
 vrrp 66 preempt delay minimum 30
 vrrp 66 timers learn
 vrrp 66 track 13 decrement 20
 vrrp 66 track 33 decrement 20
!
interface Vlan7
 ip address 10.1.7.253 255.255.255.0
 vrrp 7 ip 10.1.7.250
 vrrp 7 priority 110
 vrrp 7 preempt delay minimum 30
 vrrp 7 timers advertise msec 100

 vrrp 7 track 13 decrement 20
 vrrp 7 track 33 decrement 20
 vrrp 77 ip 10.1.7.251
 vrrp 77 priority 100
 vrrp 77 preempt delay minimum 30
 vrrp 77 timers learn
 vrrp 77 track 13 decrement 20
 vrrp 77 track 33 decrement 20

 exit
router ospf 1
 router-id 1.1.1.3
 network 10.1.6.253 0.0.0.0 area 0
 network 10.1.7.253 0.0.0.0 area 0
 network 10.1.13.3 0.0.0.0 area 0
 network 10.1.23.3 0.0.0.0 area 0
 exit

!

access-list 100 permit ip host 10.1.4.252 host 224.0.0.18
! access-list 100 permit ip host 10.1.4.253 host 224.0.0.18
access-list 100 permit ip host 10.1.5.252 host 224.0.0.18
! access-list 100 permit ip host 10.1.5.253 host 224.0.0.18
access-list 100 permit ip host 10.1.6.252 host 224.0.0.18
! access-list 100 permit ip host 10.1.6.253 host 224.0.0.18
access-list 100 permit ip host 10.1.7.252 host 224.0.0.18
! access-list 100 permit ip host 10.1.7.253 host 224.0.0.18
access-list 100 deny ip any host 224.0.0.18
access-list 100 permit ip any any
!
interface vlan 4
 ip access-group 100 in
 exit
interface vlan 5
 ip access-group 100 in
 exit
interface vlan 6
 ip access-group 100 in
 exit
interface vlan 7
 ip access-group 100 in
 exit

 IOU4

Do configure same as the HSRP configuraton.

 IOU5

Do configure same as the HSRP configuraton.

 IOU6

Do configure same as the HSRP configuraton.

 IOU7

Do configure same as the HSRP configuraton.
 PC1

ip 10.1.4.1 /24 10.1.4.250

PC1> trace 192.168.8.8

trace to 192.168.8.8, 8 hops max, press Ctrl+C to stop

 1   10.1.4.252   0.000 ms  2.000 ms  0.000 ms

 2   *10.1.12.1   0.000 ms (ICMP type:3, code:3, Destination port unreachable)
 PC2

ip 10.1.4.2 /24 10.1.4.251

PC2> trace 192.168.8.8

trace to 192.168.8.8, 8 hops max, press Ctrl+C to stop

 1   10.1.4.253   0.000 ms  0.000 ms  0.000 ms

 2   *10.1.13.1   0.000 ms (ICMP type:3, code:3, Destination port unreachable)
 

 Monitoring

 

 ==============================================================
DSW2#sh vrrp brief
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
Vl4                4   110 870        Y  Master  10.1.4.252      10.1.4.250    
Vl4                44  100 3609       Y  Master  10.1.4.252      10.1.4.251    
Vl5                5   110 870        Y  Master  10.1.5.252      10.1.5.250    
Vl5                55  100 3609       Y  Master  10.1.5.252      10.1.5.251    
Vl6                6   100 3609       Y  Master  10.1.6.252      10.1.6.250    
Vl6                66  110 870        Y  Master  10.1.6.252      10.1.6.251    
Vl7                7   100 3609       Y  Master  10.1.7.252      10.1.7.250    
Vl7                77  110 870        Y  Master  10.1.7.252      10.1.7.251    

DSW3#sh vrrp brief
Interface          Grp Pri Time  Own Pre State   Master addr     Group addr
Vl4                4   110 870        Y  Master  10.1.4.253      10.1.4.251    
Vl4                44  100 3609       Y  Master  10.1.4.253      10.1.4.250    
Vl5                5   110 870        Y  Master  10.1.5.253      10.1.5.251    
Vl5                55  100 3609       Y  Master  10.1.5.253      10.1.5.250    
Vl6                6   100 3609       Y  Master  10.1.6.253      10.1.6.251    
Vl6                66  110 870        Y  Master  10.1.6.253      10.1.6.250    
Vl7                7   100 3609       Y  Master  10.1.7.253      10.1.7.251    
Vl7                77  110 870        Y  Master  10.1.7.253      10.1.7.250    
===================================================
DSW2#show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address      Client-ID/   Lease expiration  Type       State      Interface
  Hardware address/
  User name
10.1.5.128      5000.0009.0000          Sep 01 2017 03:33 PM    Automatic  Active     Vlan5


DSW3#sh ip dhcp binding
Bindings from all pools not associated with VRF:
IP address      Client-ID/   Lease expiration  Type       State      Interface
  Hardware address/
  User name
10.1.4.128      5000.0008.0000          Sep 01 2017 12:44 PM    Automatic  Active     Vlan4
10.1.6.1        5000.000a.0000          Sep 01 2017 03:34 PM    Automatic  Active     Vlan6
10.1.7.1        5000.000b.0000          Sep 01 2017 03:35 PM    Automatic  Active     Vlan7

===================================================
DSW2#show track brief
Track Type        Instance                   Parameter        State Last Change
12    interface   Ethernet0/0                line-protocol    Up    01:06:44
22    ip sla      22                         state            Up    00:57:34

DSW3#show track brief
Track Type        Instance                   Parameter        State Last Change
13    interface   Ethernet0/1                line-protocol    Up    03:20:51
33    ip sla      33                         state            Up    01:01:20

=====================================================
DSW2#show ip sla summary
IPSLAs Latest Operation Summary
Codes: * active, ^ inactive, ~ pending

ID           Type        Destination       Stats       Return      Last
                                           (ms)        Code        Run
-----------------------------------------------------------------------
*22          udp-jitter  10.1.12.1         RTT=4       OK          12 seconds ag
                                                                   o           

DSW3#show ip sla summary
IPSLAs Latest Operation Summary
Codes: * active, ^ inactive, ~ pending

ID           Type        Destination       Stats       Return      Last
                                           (ms)        Code        Run
-----------------------------------------------------------------------
*33          udp-jitter  10.1.13.1         RTT=1       OK          5 seconds ago


===========================================
CSW1#debug ip udp port 50000
UDP packet debugging is on
CSW1#
*Sep  1 05:42:02.988: Released port 50000 in Transport Port Agent for IP type 1
*Sep  1 05:42:02.988: Released port 50000 in Transport Port Agent for IP type 1
CSW1#
CSW1#debug ip udp port 5000
*Sep  1 05:42:26.340: Reserved port 50000 in Transport Port Agent for UDP IP type 1
*Sep  1 05:42:26.342: UDP: rcvd src=10.1.12.2(49976), dst=10.1.12.1(50000), length=40
*Sep  1 05:42:26.342: UDP: sent src=10.1.12.1(50000), dst=10.1.12.2(49976), length=40
*Sep  1 05:42:26.348: UDP: rcvd src=10.1.12.2(49976), dst=10.1.12.1(50000), length=40
*Sep  1 05:42:26.348: UDP: sent src=10.1.12.1(50000), dst=10.1.12.2(49976), length=40
*Sep  1 05:42:26.355: UDP: rcvd src=10.1.12.2(49976), dst=10.1.12.1(50000), length=40
*Sep  1 05:42:26.355: UDP: sent src=10.1.12.1(50000), dst=10.1.12.2(49976), length=40
*Sep  1 05:42:26.356: UDP: rcvd src=10.1.12.2(49976), dst=10.1.12.1(50000), length=40
*Sep  1 05:42:26.356: UDP: sent src=10.1.12.1(50000), dst=10.1.12.2(49976), length=40
*Sep  1 05:42:26.362: UDP: rcvd src=10.1.12.2(49976), dst=10.1.12.1(50000), length=40
*Sep  1 05:42:26.362: UDP: sent src=10.1.12.1(50000), dst=10.1.12.2(49976), length=40
*Sep  1 05:42:26.364: UDP: rcvd src=10.1.12.2(49976), dst=10.1.12.1(50000), length=40
*Sep  1 05:42:26.364: UDP: sent src=10.1.12.1(50000), dst=10.1.12.2(49976), length=40
*Sep  1 05:42:26.370: UDP: rcvd src=10.1.12.2(49976), dst=10.1.12.1(50000), length=40
CSW1#debug ip udp p       
*Sep  1 05:42:26.370: UDP: sent src=10.1.12.1(50000), dst=10.1.12.2(49976), length=40
*Sep  1 05:42:26.372: UDP: rcvd src=10.1.12.2(49976), dst=10.1.12.1(50000), length=40
*Sep  1 05:42:26.372: UDP: sent src=10.1.12.1(50000), dst=10.1.12.2(49976), length=40
*Sep  1 05:42:26.377: UDP: rcvd src=10.1.12.2(49976), dst=10.1.12.1(50000), length=40
*Sep  1 05:42:26.378: UDP: sent src=10.1.12.1(50000), dst=10.1.12.2(49976), length=40
*Sep  1 05:42:26.379: UDP: rcvd src=10.1.12.2(49976), dst=10.1.12.1(50000), length=40
*Sep  1 05:42:26.379: UDP: sent src=10.1.12.1(50000), dst=10.1.12.2(49976), length=40
CSW1#             
*Sep  1 05:42:37.055: Released port 50000 in Transport Port Agent for IP type 1
*Sep  1 05:42:37.055: Released port 50000 in Transport Port Agent for IP type 1
CSW1#
*Sep  1 05:42:52.920: Reserved port 50000 in Transport Port Agent for UDP IP type 1
*Sep  1 05:42:52.921: UDP: rcvd src=10.1.13.3(55741), dst=10.1.13.1(50000), length=40
*Sep  1 05:42:52.921: UDP: sent src=10.1.13.1(50000), dst=10.1.13.3(55741), length=40
*Sep  1 05:42:52.932: UDP: rcvd src=10.1.13.3(55741), dst=10.1.13.1(50000), length=40
*Sep  1 05:42:52.932: UDP: sent src=10.1.13.1(50000), dst=10.1.13.3(55741), length=40
*Sep  1 05:42:52.935: UDP: rcvd src=10.1.13.3(55741), dst=10.1.13.1(50000), length=40
*Sep  1 05:42:52.935: UDP: sent src=10.1.13.1(50000), dst=10.1.13.3(55741), length=40
*Sep  1 05:42:52.946: UDP: rcvd src=10.1.13.3(55741), dst=10.1.13.1(50000), length=40
*Sep  1 05:42:52.946: UDP: sent src=10.1.13.1(50000), dst=10.1.13.3(55741), length=40
*Sep  1 05:42:52.948: UDP: rcvd src=10.1.13.3(55741), dst=10.1.13.1(50000), length=40
*Sep  1 05:42:52.948: UDP: sent src=10.1.13.1(50000), dst=10.1.13.3(55741), length=40
*Sep  1 05:42:52.950: UDP: rcvd src=10.1.13.3(55741), dst=10.1.13.1(50000), length=40
*Sep  1 05:42:52.950: UDP: sent src=10.1.13.1(50000), dst=10.1.13.3(55741), length=40
*Sep  1 05:42:52.957: UDP: rcvd src=10.1.13.3(55741), dst=10.1.13.1(50000), length=40
CSW1#
*Sep  1 05:42:52.957: UDP: sent src=10.1.13.1(50000), dst=10.1.13.3(55741), length=40
*Sep  1 05:42:52.958: UDP: rcvd src=10.1.13.3(55741), dst=10.1.13.1(50000), length=40
*Sep  1 05:42:52.958: UDP: sent src=10.1.13.1(50000), dst=10.1.13.3(55741), length=40
*Sep  1 05:42:52.964: UDP: rcvd src=10.1.13.3(55741), dst=10.1.13.1(50000), length=40
*Sep  1 05:42:52.964: UDP: sent src=10.1.13.1(50000), dst=10.1.13.3(55741), length=40
*Sep  1 05:42:52.966: UDP: rcvd src=10.1.13.3(55741), dst=10.1.13.1(50000), length=40
*Sep  1 05:42:52.966: UDP: sent src=10.1.13.1(50000), dst=10.1.13.3(55741), length=40

 

 

GLBP Setting

GLBP.zip

 IOU1

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

hostname CSW1

no ip cef

no cdp run
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 exit
interface Loopback1
 ip address 192.168.8.8 255.255.255.255
 ip ospf network point-to-point
 exit
interface Ethernet0/0
 description face to iou2's e0/0
 no switchport
 ip address 10.1.12.1 255.255.255.0
 no shutdown
 exit
interface Ethernet0/1
 description face to iou3's e0/1
 no switchport
 ip address 10.1.13.1 255.255.255.0
 no shutdown
 exit
router ospf 1
 router-id 1.1.1.1
 redistribute connected subnets
 network 10.1.12.1 0.0.0.0 area 0
 network 10.1.13.1 0.0.0.0 area 0

 IOU2

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

hostname DSW2

no ip cef

no cdp run
ip dhcp excluded-address 10.1.4.128 10.1.4.254
ip dhcp excluded-address 10.1.5.128 10.1.5.254
ip dhcp excluded-address 10.1.6.128 10.1.6.254
ip dhcp excluded-address 10.1.7.128 10.1.7.254
!
ip dhcp pool vlan4
 network 10.1.4.0 255.255.255.0
 default-router 10.1.4.254
 dns-server 192.168.8.2
 lease 0 8
 exit
ip dhcp pool vlan5
 network 10.1.5.0 255.255.255.0
 default-router 10.1.5.254
 dns-server 192.168.8.2
 lease 0 8
 exit
ip dhcp pool vlan6
 network 10.1.6.0 255.255.255.0
 default-router 10.1.6.254
 dns-server 192.168.8.2
 lease 0 8
 exit
ip dhcp pool vlan7
 network 10.1.7.0 255.255.255.0
 default-router 10.1.7.254
 dns-server 192.168.8.2
 lease 0 8
 exit
no ip cef

no cdp run
!
track 12 interface Ethernet0/0 line-protocol
 carrier-delay
 exit

track 18 ip sla 18

!

ip sla 18
 udp-jitter 10.1.12.1 50000
 frequency 5

 exit
ip sla schedule 18 life forever start-time now
!
interface Loopback0
 ip address 1.1.1.2 255.255.255.255
 exit
interface Ethernet0/0
 description face to iou1's e0/0
 no switchport
 ip address 10.1.12.2 255.255.255.0
 no shutdown

interface Ethernet0/1
 switchport access vlan 4
 switchport mode access
!
interface Ethernet0/2
 switchport access vlan 5
 switchport mode access
!
interface Ethernet0/3
 switchport access vlan 6
 switchport mode access
!
interface Ethernet1/0
 switchport access vlan 7
 switchport mode access
!
interface Ethernet1/2
 description face to iou3's e1/2
 no switchport
 ip address 10.1.23.2 255.255.255.0
 no shutdown
 exit

!
interface Vlan4
 ip address 10.1.4.252 255.255.255.0
 glbp 4 ip 10.1.4.254

 glbp 4 priority 110

 glbp 4 preempt

 glbp 4 weighting 110 lower 85 upper 105

 glbp 4 load-balancing weighted

 glbp 4 name vlan4

 glbp 4 weighting track 12 decrement 20

 glbp 4 weighting track 18 decrement 20

interface Vlan5
 ip address 10.1.5.252 255.255.255.0
 glbp 5 ip 10.1.5.254

 glbp 5 priority 110

 glbp 5 preempt

 glbp 5 weighting 110 lower 85 upper 105

 glbp 5 load-balancing weighted

 glbp 5 name vlan5

 glbp 5 weighting track 12 decrement 20

 glbp 5 weighting track 18 decrement 20

!
interface Vlan6
 ip address 10.1.6.252 255.255.255.0
 glbp 6 ip 10.1.6.254

 glbp 6 priority 110

 glbp 6 preempt

 glbp 6 weighting 110 lower 85 upper 105

 glbp 6 load-balancing weighted

 glbp 6 name vlan6

 glbp 6 weighting track 12 decrement 20

 glbp 6 weighting track 18 decrement 20

!
interface Vlan7
 ip address 10.1.7.252 255.255.255.0
 glbp 7 ip 10.1.7.254

 glbp 7 priority 110

 glbp 7 preempt

 glbp 7 weighting 110 lower 85 upper 105

 glbp 7 load-balancing weighted

 glbp 7 name vlan7

 glbp 7 weighting track 12 decrement 20

 glbp 7 weighting track 18 decrement 20
 

 exit
!
router ospf 1
 router-id 1.1.1.2
 network 10.1.4.252 0.0.0.0 area 0
 network 10.1.5.252 0.0.0.0 area 0
 network 10.1.12.2 0.0.0.0 area 0
 network 10.1.23.2 0.0.0.0 area 0
 exit

 IOU3

enable

configure termianl

line console 0

 logg s

 exec-t 0

 exit

no ip cef

no cdp run

!
hostname DSW3
!
ip dhcp excluded-address 10.1.4.1 10.1.4.127
ip dhcp excluded-address 10.1.5.1 10.1.5.127
ip dhcp excluded-address 10.1.6.1 10.1.6.127
ip dhcp excluded-address 10.1.7.1 10.1.7.127
!
ip dhcp pool vlan4
 network 10.1.4.0 255.255.255.0
 default-router 10.1.4.254
 dns-server 192.168.8.2
 lease 0 8
!
ip dhcp pool vlan5
 network 10.1.5.0 255.255.255.0
 default-router 10.1.5.254
 dns-server 192.168.8.2
 lease 0 8
!
ip dhcp pool vlan6
 network 10.1.6.0 255.255.255.0
 default-router 10.1.6.254
 dns-server 192.168.8.2
 lease 0 8
!
ip dhcp pool vlan7
 network 10.1.7.0 255.255.255.0
 default-router 10.1.7.254
 dns-server 192.168.8.2
 lease 0 8
!
track 13 interface Ethernet0/1 line-protocol
 carrier-delay
!
track 18 ip sla 18

!
interface Loopback0
 ip address 1.1.1.3 255.255.255.255
!
interface Ethernet0/1
 description face to iou1's e0/1
 no switchport
 ip address 10.1.13.3 255.255.255.0
 no shutdown
 exit
interface Ethernet0/2
 switchport access vlan 4
 switchport mode access
!
interface Ethernet0/3
 switchport access vlan 5
 switchport mode access
!
interface Ethernet1/0
 switchport access vlan 6
 switchport mode access
!
interface Ethernet1/1
 switchport access vlan 7
 switchport mode access
!
interface Ethernet1/2
 description face to iou2's e1/2
 no switchport
 ip address 10.1.23.3 255.255.255.0
 no shutdown
 exit
!
interface Vlan4
 ip address 10.1.4.253 255.255.255.0
 glbp 4 ip 10.1.4.254

 glbp 4 priority 100

 glbp 4 preempt

 glbp 4 weighting 110 lower 85 upper 105

 glbp 4 load-balancing weighted

 glbp 4 name vlan4

 glbp 4 weighting track 12 decrement 20

 glbp 4 weighting track 18 decrement 20

 

interface Vlan5
 ip address 10.1.5.253 255.255.255.0
 glbp 5 ip 10.1.5.254

 glbp 5 priority 100

 glbp 5 preempt

 glbp 5 weighting 110 lower 85 upper 105

 glbp 5 load-balancing weighted

 glbp 5 name vlan5

 glbp 5 weighting track 12 decrement 20

 glbp 5 weighting track 18 decrement 20

!
interface Vlan6
 ip address 10.1.6.253 255.255.255.0
 glbp 6 ip 10.1.6.254

 glbp 6 priority 100

 glbp 6 preempt

 glbp 6 weighting 110 lower 85 upper 105

 glbp 6 load-balancing weighted

 glbp 6 name vlan6

 glbp 6 weighting track 12 decrement 20

 glbp 6 weighting track 18 decrement 20

!
interface Vlan7
 ip address 10.1.7.253 255.255.255.0
 glbp 7 ip 10.1.7.254

 glbp 7 priority 100

 glbp 7 preempt

 glbp 7 weighting 110 lower 85 upper 105

 glbp 7 load-balancing weighted

 glbp 7 name vlan7

 glbp 7 weighting track 12 decrement 20

 glbp 7 weighting track 18 decrement 20

router ospf 1
 router-id 1.1.1.3
 network 10.1.6.253 0.0.0.0 area 0
 network 10.1.7.253 0.0.0.0 area 0
 network 10.1.13.3 0.0.0.0 area 0
 network 10.1.23.3 0.0.0.0 area 0
!
ip sla 18
 udp-jitter 10.1.12.1 50000
 frequency 5
ip sla schedule 18 life forever start-time now
 exit

 IOU4

Do configure same as the HSRP configuraton.

 IOU5

Do configure same as the HSRP configuraton.

 IOU6

Do configure same as the HSRP configuraton.

 IOU7

Do configure same as the HSRP configuraton.

 

Overview

 

When designing a network, one of the common things to focus on after simple access is how the network will deal with failure. Part of this process is trying to build as much redundancy into the design as financially possible, while also maintaining performance and manageability. From the client’s perspective, the first piece of the network they deal without, outside of their local subnet, is the default gateway; if this gateway were to go down, then access to an entire subnet (at least) would go down. One of the ways to deal with this is to implement a first hop redundancy protocol. On Cisco equipment, there are a couple of different options to choose from, including Hot Standby Router Protocol (HSRP), Virtual Router Redundancy Protocol (VRRP) and Gateway Load Balancing Protocol (GLBP). This article gives an overview of these options and how they differ.

 

 

 

 

 

Hot Standby Router Protocol (HSRP)

 

HSRP is a Cisco proprietary protocol that enables the network engineer to configure multiple redundant routers that exist on the same subnet; each can be used as a gateway for the devices on the subnet. Without HSRP, each of the devices on the subnet would need to be individually configured to use a specific gateway, effectively not providing redundancy but limiting the number of clients that would be affected if a router were to go down. With HSRP, a group of routers (gateways) will be configured together, and a single HSRP virtual IP address and MAC address will be created that are used by the devices on the subnet. The different routers in the HSRP will communicate to a select single active gateway that handles all live traffic. At this point, a single standby gateway is also selected. This standby gateway communicates with the active gateway via multicast and will detect should the active gateway fail. When this happens, one of the standby gateways will take over the duties of the active gateway and continue traffic forwarding without much (if any) delay. When this happens, a new standby gateway is also selected.

 

 

 

Virtual Router Redundancy Protocol (VRRP)

 

VRRP is an open standard that can be used in environments where equipment from multiple vendors exists. Its operation is similar to HSRP but differs in a couple of ways. In VRRP, like with HSRP, a group is configured that contains a number of routers (gateways); one will be selected by the network engineer to be the master. The master router’s physical IP address of the interface connecting the subnet is used by the clients as a default gateway. The backup members of the VRRP group will communicate with the master gateway and take over the duties of forwarding traffic, should the master fail. The IP address used always belongs to the master router which is referred to as the IP address owner. When the master router recovers, it will take back the duties of routing for that IP address.

 

It is possible to have multiple VRRP groups on a single subnet, which can be used to spread the load of the traffic coming off of a subnet. However, this must be done manually at the client’s location, by changing their default gateway addresses.

 

 

 

Gateway Load Balancing Protocol (GLBP)

 

GLBP is another Cisco proprietary protocol that can be used for first hop redundancy. GLBP offers something that the first two does not: dynamic load balancing. With GLBP, unlike HSRP or VRRP, all of the routers that exist within the GLBP group are active and are forwarding traffic. When a GLBP group is configured, one of the routers within the group will be elected as the Active Virtual Gateway (AVG); each of the other routers will back up the AVG, should it fail. The AVG is responsible for assigning virtual MAC addresses to each of the members of the GLBP group; each of these members is referred to as an Active Virtual Forwarder (AVF). The AVG is responsible for responding to ARP request by subnet devices, and selecting which group’s router will handle the traffic. The IP address of the default gateway is the same across all of the subnet devices; this IP address is virtual.  When the device ARPs for a MAC address, the AVG will respond with one of the virtual MAC addresses. This way, the AVG is able to control which router will handle the load of each individual subnet device.

 

Summary

 

Obviously, like most things in networking, there are a number of options available which can each be used to solve a specific problem. Two of the three solutions discussed above are specific to Cisco equipment, and thus can only be used in implementations where only Cisco equipment is used (at least across the gateways). VRRP is an option implementation which is supported on multiple vendors’ equipment and thus provides an option that opens the door to non-Cisco equipment. GLBP offers the ability to dynamically load balance traffic, which is a big advantage as it takes advantage of all available bandwidth and does not waste these resources. Which one to select depends a great deal on the specific situation and should each be considered depending on the details of the implementation. Hopefully the content of this article will at least give the reader an idea of the available options that can be used to solve this problem. 

 Refer site : https://www.petri.com/cisco-first-hop-redundancy-protocols